Blog of Raivo Laanemets

Stories about web development, freelancing and personal computers.

Compiling Bootstrap: grunt peerDependencies

On

When compiling Bootstrap 3.1.1 you might get the error:

The package grunt does not satisfy its siblings' peerDependencies requirements!.

Solution: use code directly from the Bootstrap git master branch.

Relevant bug report: https://github.com/twbs/bootstrap/issues/13527. The right solution: who knows, grunt is too complex.


Comments

No comments have been added so far.

Email is not displayed anywhere.
URLs (max 3) starting with http:// or https:// can be used. Use @Name to mention someone.